»查看更多分类股票软件

RM3线一线阴线 通达信主图指标 源码 贴图

发布时间:2020-05-01 09:48:00  点击:

RM3线一线阴线 通达信主图指标 源码 贴图

RM3线一线法:
1 上RM3线,当天线向下,下一天线向上(打46键预测),当天收盘RM3线乖离率小于3.5,可收盘进或下一天开盘进,当天线向上,开始做。
2 线向上,一律开盘线乖离率小于2进, 收盘线乖离率小于3.5可进, 卖出股后阴线极近RM3可以收盘收回。
3 线向上,涨五天后,涨第六天开始、只要上一天开在线下当天就只卖不买,涨第六天开始, 线向上,只要开在线上下一天继续做下去。
4 卖日是阴线 做阴线法,线向下一样做

RM3线一线阴线 通达信主图指标 源码 贴图


MA5:=MA(CLOSE,5)COLORGREEN;

MA5角度:=ATAN((MA5/REF(MA5,1)-1)*100)*180/3.1416,NODRAW,COLORWHITE;
一:C*1.012,NODRAW,COLORRED;
二:C*1.022,NODRAW,COLOR00FFFF;
三:C*1.032,NODRAW,COLORGREEN;
四:C*1.042,NODRAW,COLOR00FFFF;
五:C*1.052,NODRAW,COLORGREEN;
六:C*1.062,NODRAW,COLORWHITE;
七:C*1.072,NODRAW,COLOR00FFFF;
八:C*1.082,NODRAW,COLORGREEN;
九:C*1.092,NODRAW;
十:C*1.102,NODRAW,COLORFF00FF;
十一:C*1.112,NODRAW,COLORRED;
十二:C*1.122,COLORYELLOW,NODRAW;
十五:C*1.152,NODRAW;
二十:C*1.202,NODRAW;
三十:C*1.302,NODRAW,COLORRED;
F:=100*(C-REF(C,1))/REF(C,1);
STICKLINE(F>4.9,C,O,2.2,0),COLORFFFFFF;
今小昨:=IF(C<REF(O,1) AND F<0,1,0);
P1:=今小昨;
今小前:=IF(C<REF(O,2) AND F<0,1,0);
P2:=今小前;
STICKLINE(P1=0 AND REF(P1,1)=1 AND P2=0 AND REF(P2,1)=1,OPEN,CLOSE,1,0),COLORMAGENTA;

A1:=CLOSE;
A2:=OPEN;

STICKLINE(A1<A2 AND F<=-9.9,A2,A1,3,0),COLOR00FF00;

STICKLINE(P1=1 AND REF(P1,1)=0 AND P2=1 AND REF(P2,1)=0,OPEN,CLOSE,1,0),COLORAAAAAA;
STICKLINE(A1<A2 AND F<-2.9 AND F>-5,A1+(A2-A1)/3,A1+(A2-A1)/3,1,0),COLORRED;
STICKLINE(A1<A2 AND F<-2.9 AND F>-5,A1+2*(A2-A1)/3,A1+2*(A2-A1)/3,1,0),COLORRED;
STICKLINE(A1<A2 AND F<=-5 AND F>-7,A1+(A2-A1)/2,A1+(A2-A1)/2,1,0),COLORRED;
STICKLINE(A1<A2 AND F<=-7 AND F>-10,A1+2*(A2-A1)/3,A1+(A2-A1)/3,3,1),COLORRED;
STICKLINE(A1>A2 AND F>2.9 AND F<5,A2+(A1-A2)/3,A2+(A1-A2)/3,1,0),COLORYELLOW;
STICKLINE(A1>A2 AND F>2.9 AND F<5,A2+2*(A1-A2)/3,A2+2*(A1-A2)/3,1,0),COLORYELLOW;
STICKLINE(A1>A2 AND F>=5.5 AND F<7,A2+(A1-A2)/2,A2+(A1-A2)/2,1,0),COLORYELLOW;
STICKLINE(A1>A2 AND F>=7 AND F<9.8,A2+2*(A1-A2)/3,A2+(A1-A2)/3,1,1),COLORYELLOW;
{STICKLINE(P1=1 AND REF(P1,1)=0 AND P2=1 AND REF(P2,1)=0,OPEN,CLOSE,1,0),COLORAAAAAA;}
{出标志}
F1:=100*(C-REF(C,1))/REF(C,1);
HT:=(H>REF(C,1)*1.032) AND C>=O ;
BZ1A:=HT AND H>REF(H,2);
BZ1:=BZ1A AND COUNT(BZ1A,4)=1;
一字:=C=O AND C=L AND C=H AND F1>9.4;
BZ2:=((BZ1 AND REF(BZ1,1)=0) OR REF(一字,1)=1)
AND 一字=0 ;
DRAWTEXT(BZ2,L*0.99, '标'),COLORYELLOW;
{出黄头}
STICKLINE(H>(REF(C,1)*1.032),(O+C)/2,H,0.1,0),COLOR00FFFF;
M3:=MA(CLOSE,3)COLORGREEN;
{RM3}
RM3: (REF(MA(C,3),1)) ,COLOR00FFFF;
M5:=MA(CLOSE,5),COLOR00FFFF;
IF(M5<REF(M5,1),RM3,DRAWNULL),COLORFFF000;
K9:=((EMA(KDJ.K,3)-50)*2);
IF(K9>REF(K9,1),RM3,DRAWNULL),COLORF000FF;
IF(K9>REF(K9,1),RM3,DRAWNULL),POINTDOT,COLOR0000FF,LINETHICK5;
线买最高涨:100*(H-REF(RM3,1))/REF(RM3,1),NODRAW,COLOR00FFFF;
{线买赚四点:RM3*1.042,NODRAW,COLORWHITE;}
RM3角度:ATAN((RM3/REF(RM3,1)-1)*100)*180/3.1416,NODRAW,COLORWHITE;
BIAS5:=((CLOSE-MA(CLOSE,5))/MA(CLOSE,5)*100),NODRAW,COLOR00FFFF;
{昨CC半,上一天实体一半偏上一点位置}
{}
DA:=MAX(C,O);
DB:=MIN(C,O);
CC半A:=(DA-(DA-DB)/2.5);
CC半:=IF(C>O,CC半A,C),NODRAW;
昨CC半:=REF(CC半,1),COLORYELLOW,NODRAW;
昨CC半买涨:100*(H-REF(昨CC半,1))/REF(昨CC半,1),COLOR88AAFF,NODRAW;
STICKLINE(ISLASTBAR,昨CC半,昨CC半,10,-1),COLORFF66CC;
明线乖3点5:M3*1.02 ,NODRAW,COLORWHITE;
昨线乖高赚:100*(H-REF(明线乖3点5,2))/REF(明线乖3点5,2),COLOR00FFFF,NODRAW;
收线乖:((CLOSE-RM3)/RM3*100),NODRAW,COLOR00FFFF;
最底线乖:((L-RM3)/RM3*100),NODRAW,COLOR00FFFF;
开线乖:((O-RM3)/RM3)*100,NODRAW,COLOR00FFFF;

FH:=100*(H-REF(C,1))/REF(C,1),COLOR88AAFF,NODRAW;
F4:=(C/REF(C,1)-1)*100;
今小昨1:=IF(C<REF(O,1) AND F4<0,1,0);
P11:=今小昨1;
今小前1:=IF(C<REF(O,2) AND F4<0,1,0);
P21:=今小前1;
ZY1:=P11=0 AND REF(P11,1)=1 AND P21=0 AND REF(P21,1)=1;
ZY11:=REF(L,BARSLAST(ZY1));
ZY2:=CROSS(ZY11,C) AND ZY1=0;

STICKLINE(ISLASTBAR ,REF(C,1)*1.042,REF(C,1)*1.042,0,-1),COLOR00FFFF;{把前面第一个C改成 ISLASTBAR 就只有最后一天有黄虚线}
DRAWNUMBER(ISLASTBAR,REF(C,1)*1.03-0.03,REF(C,1)*1.042),COLOR00FFFF;

A3:=C>REF(C,4);
NT:=BARSLASTCOUNT(A3);
TJ11:=NT=9;
TJ13:=ISLASTBAR AND BETWEEN(NT,5,8);
AY:=(BACKSET(TJ11>0,9) OR BACKSET(TJ13>0,NT))*NT;
DRAWTEXT(AY>0,H*1.02,VAR2STR(AY,0)),COLORFF00FF;
DRAWTEXT(NT=9,H*1.02,'9'),COLORGREEN;
B1:=C<REF(C,4);
NT0:=BARSLASTCOUNT(B1);
TJ21:=NT0=9 ;
WWW70822COM:=NT0=9;
TJ23:=ISLASTBAR AND BETWEEN(NT0,5,8);
AY1:=(BACKSET(TJ21>0,9) OR BACKSET(TJ23>0,NT0))*NT0;
DRAWTEXT(AY1>0,L*0.98,VAR2STR(AY1,0)),COLORFF00FF;
DRAWTEXT(NT0=9,L*0.98,'9'),COLORGREEN;



所属板块:=STRCAT('【所属板块】',STRCAT(STRCAT(STRCAT(' [行业]—',HYBLOCK),STRCAT(' [地域]—',DYBLOCK)),STRCAT(' [概念]—',GNBLOCK)));
总股本:=STRCAT(STRCAT(' 总股本:',CON2STR(TOTALCAPITAL/1000000,2)),'亿');
流通盘:=STRCAT(STRCAT(' 流通盘:',CON2STR(CAPITAL/1000000,2)),'亿');
全流通:=STRCAT(STRCAT(' 流通比:',CON2STR(CAPITAL/TOTALCAPITAL*100,2)),'%');
市值:=STRCAT(STRCAT(' 流通市值:',CON2STR((CAPITAL/1000000)*C,2)),'亿');
上市日期:=STRCAT(' 上市日期: ',CON2STR(HHV((BARSCOUNT(C)=0)*(DATE+19000000),0),0));
股本市值:=STRCAT('【股本市值】',STRCAT(STRCAT(STRCAT(STRCAT(总股本,流通盘),全流通),市值),上市日期));
市盈率:=STRCAT(' 市盈率:',CON2STR(C/FINANCE(33),2));
市销率:=STRCAT(' 市销率:',CON2STR(C/(FINANCE(20)/FINANCE(1)),2));
市净率:=STRCAT(' 市净率:',CON2STR(C/FINANCE(34),2));
净资收益率:=STRCAT(' 净资收益率:',CON2STR(FINANCE(33)/FINANCE(34)*100,2));
毛利率:=STRCAT(' 毛利率:',CON2STR((FINANCE(20)-FINANCE(21))/FINANCE(20)*100,2));
净利润率:=STRCAT(' 净利率:',CON2STR(FINANCE(30)/FINANCE(20)*100,2));
主营利润率:=STRCAT(' 主营利润率:',CON2STR(FINANCE(23)/FINANCE(20)*100,2));
当前业绩:=STRCAT('【当前业绩】',STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(市盈率,市销率),市净率),净资收益率),毛利率),净利润率),主营利润率));
DRAWTEXT_FIX(ISLASTBAR,0.005,0.02,0,所属板块),COLORMAGENTA;
DRAWTEXT_FIX(ISLASTBAR,0.005,0.07,0,股本市值),COLORMAGENTA;
DRAWTEXT_FIX(ISLASTBAR,0.005,0.12,0,当前业绩),COLORMAGENTA;
DRAWTEXT_FIX(1,0.005,0.17,0,'莸利比例:'),COLORYELLOW;
DRAWNUMBER_FIX(1,0.06,0.17,0,CONST(WINNER(C )*100)),COLORYELLOW;
DRAWNUMBER_FIX(1,0.15,0.17,0,CONST(DYNAINFO(37)*100)),COLORYELLOW;
DRAWTEXT_FIX (1,0.12,0.17,0,'换手:'),COLORYELLOW;
DRAWNUMBER_FIX(1,0.25,0.17,0,CONST(DYNAINFO(17))),COLORYELLOW;
DRAWTEXT_FIX (1,0.22,0.17,0,'量比:'),COLORYELLOW;
DRAWTEXT_FIX (1,0.30,0.17,0,'涨幅:'),COLORYELLOW;
DRAWNUMBER_FIX(1,0.33,0.17,0,CONST(DYNAINFO(14)*100)),COLORYELLOW;
DRAWNUMBER_FIX(1,0.33,0.17,0,IF(CONST(DYNAINFO(14)*100)<0,CONST(DYNAINFO(14)*100),DRAWNULL)),COLORYELLOW;
X1:=(FINANCE(11)-FINANCE(15))/FINANCE(10)*1.2;
X2:=(FINANCE(31)+FINANCE(17))/FINANCE(10)*1.4;{盈余公积用资本公积金代替};
X3:=FINANCE(23)/FINANCE(10)*3.3;
X4:=FINANCE(19)/FINANCE(15)*0.6;{缺长期负债或负债总额}
X5:=FINANCE(20)/FINANCE(15)*0.999;
Z值:=X1+X2+X3+X4+X5;
预警:=IF(Z值<1.2,'重警',IF(Z值>=1.2 AND Z值<2.6,'轻警','无警'));
财务预警:=STRCAT('财务预警: ',STRCAT(预警,STRCAT('-Z值: ',CON2STR(Z值,3))));
优质资产率:=STRCAT(' 优质资产率: ',CON2STR((FINANCE(19)-FINANCE(22)-FINANCE(27))/FINANCE(19),2));{理论上越大越好但不同行业有不同标准};
现金负债比:=STRCAT(' 现金负债比: ',CON2STR(FINANCE(25)/FINANCE(15),3));{缺长期负债或负债总额,理论上越大越好但不同行业有不同标准};
财务系数:=STRCAT('风险系数: ',STRCAT(STRCAT(财务预警,优质资产率),现金负债比));
DRAWTEXT_FIX(ISLASTBAR,0.005,0.23,0,财务系数),COLORGREEN;



R1:=(C+L+H)/3;
R2:=EMA(R1,6);
R3:=EMA(R2,5);
生命线:EMA(R3,30),COLOR00AAFF,LINETHICK2;
N:=5;
M1:=6;
M2:=6;
M4:=8;
R:=IF(DATE<1910612,1,0);
EE:=(H+MAX(C,O))/2;
EE1:=MA(EE,3);
EE2:=(L+MIN(C,O))/2;
EE3:=MA(EE2,3);

FF:=(H+L+C+O)/4,COLORWHITE;
FF1:=MA(FF,3),COLORGREEN;
FF3:=REF((C+O)/2,1)>REF((C+O)/2,2) AND REF(MIN(C,O),1)>REF(MAX(C,O),2);
实际乖离:=(MAX(FF,FF1)-MIN(FF,FF1))/MIN(FF,FF1)*100,LINETHICK;
FF4:=(((FF1-(REF(FF1,1)-FF1))-L)/L)*100;
FF5:=(((EE1+(EE1-REF(EE1,1)))-L)/L)*100;
FF6:=FF1-(REF(FF1,1)-FF1);
FF7:=EE1+(EE1-REF(EE1,1));
期望获利率:=IF(FF3,FF5,FF4),LINETHICK;
YY1:=REF(EVERY(C>=O,4),1) AND REF(EVERY((C+O)/2>FF1,4),1) AND (C+O)/2<FF1;
YY2:=NOT(YY1) AND (FF1-O)/O*1000>5 AND O<REF(MIN(C,O),1);
A:=SMA(L,4,3);
B:=SMA(H,4,3);
BB:=SMA(MIN(C,O),4,3);
BB1:=REF(L,1)-HHV((MAX(REF(L,2),REF(L,1))-MIN(REF(L,2),REF(L,1))),2);
BB2:=REF((C+O)/2,1)>REF((C+O)/2,2);
BB3:=L<=BB1+BB1*0.01 AND O>REF(O,2) AND O>=REF(L,3) AND COUNT(C>O,7)>3;
BB6:=(BB1-L)/L*100;
BB7:=(REF(L,1)-BB1)/BB1*100;
A4:=(A-L)/L>N/1000 ;
A8:=A4;
A9:=(REF(H,1)-O)/O*100-(REF(MAX(C,O),2)-REF(MAX(C,O),1))/REF(MAX(C,O),1)*100;
A10:=IF(BB2,BB6,A9);
BB4:=BB6+A10>2;
BB5:=IF(BB2,BB3,BB4) AND 期望获利率>2;
D5:=R AND A8 AND BB5;
STICKLINE(D5,A*0.995,A*0.992,4,0)COLORYELLOW;
DRAWICON(R AND (REF((D5),1)) AND (L<REF((L/0.995),1)),L*0.97,11);

 
RM3线一线阴线 通达信主图指标 源码 贴图
打开微信扫一扫,一键复制指标源码,
轻松快捷粘贴至手机通达信APP中。
0

本站提示:股市有风险,入市请慎重,资料由股票下载资讯网整理收集

找不到你要的公式?给我们建议

  1. 股票软件
    股票分析软件
    股票交易软件
    股票行情软件
    指标股票池
    手机炒股软件
    书籍教程
    数据软件
    工具补丁
    大智慧
    通达信
    飞狐
    东方财富通
    操盘手
    指南针
    分析家
    同花顺
    钱龙
    证券之星
    券商股票软件
    特色行情软件
    迷你行情软件
    金融界软件
    美股外盘软件
    大智慧股票池
    通达信股票池
    大智慧L2公式
    通达信公式
    飞狐公式
    同花顺公式
    股票书藉
    视频教程
    金融书籍
    其他书籍
    资讯评测软件
    资金分析软件
    数据接口软件
    江恩波浪软件
    数据下载软件
    软件数据投资
    选股软件
    登录补丁
    其他应用
    股软教程
  2. 股票公式
    通达信公式
    大智慧公式
    飞狐公式
    同花顺公式
    东方财富通公式
    金字塔指标公式
    文华指标公式
    MT4指标
    博易大师指标
    公式教程答疑
  3. 炒股知识
    短线技巧
    软件公式
    炒股视频
    股票入门
    股市实战信息交流
    炒股技巧
    股票基础知识
    技术分析
    炒股一招先
    基本面分析
    股票视频教程
    股票买卖技巧
    k线图分析
    胡立阳教你买股票
    短线炒股技巧
    天狼之眼
    波浪理论技术讲解
    股市赢家杨百万
    股票理论、T0缠论、知识
    经典指标、交易系统
    成交量能、筹码分析
    买卖信号、技术分析
    挖坑、冼盘、吸筹、出货
    均线战法、黄金分割
    经典K线、趋势形态
    牛股黑马、王子理论
    涨停、周线、月线
    止盈、止损、支撑、压力
    案例、波浪、口诀、选股
    分时、盘口、补仓、解套
  4. 技术指标
    DDX
    DDY
    DDZ
    MACD
    KDJ
    CCI
    OBV
    BOLL
    RSI
    VOL
    CR
    WR